Update: SafeArrival & SchoolMessenger App for Canada-based customers
Incident Report for SchoolMessenger
Resolved
This specific issue has been resolved.
Posted Oct 09, 2018 - 11:36 CDT
Monitoring
At this time, SafeArrival Admin interface and SchoolMessenger App (mobile app and web interfaces) for Canada-based customers, as well as the parent interfaces, are fully functional.

Please subscribe to active incidents here for real-time updates via email and/or SMS.
Posted Oct 03, 2018 - 21:00 CDT
This incident affected: Communicate (SafeArrival, SchoolMessenger App).